BlazingSQL Documentation

Welcome to our Documentation and Support Page!

BlazingSQL is a GPU accelerated SQL engine built on top of the RAPIDS AI data science framework. RAPIDS AI is a collection of open-source libraries for end-to-end data science pipelines entirely in the GPU. BlazingSQL extends RAPIDS AI and enables users to run SQL queries on Apache Arrow in GPU memory.

Please install, test, deploy, and gripe in our Discussion board.

Get Started
Ask A Question



Unable to install blazingsql files

Hi all, After testing blazingsql on google colab, I found the memory provided on google vm is limited. So I tried to install blazingsql on a linux GPU virtual machine. After setting up miniconda and creating a new environment with python 3.6, I ran the following to download the files bash -c "$(wget -q -O -)" However, I get following errors (only a sample of errors below): I am not sure why it says file exists. Any thoughts much appreciated. 2019-06-19 13:19:51 (266 MB/s) - written to stdout [5833/5833] tar: blazingsql-files/BlazingCalcite.jar: Cannot open: File exists tar: blazingsql-files/libhdfs3/ Cannot open: File exists tar: blazingsql-files/libhdfs3: Cannot utime: Operation not permitted tar: blazingsql-files/nvstrings-src/img/rapids_logo.png: Cannot open: File exists tar: blazingsql-files/nvstrings-src/img: Cannot utime: Operation not permitted tar: blazingsql-files/nvstrings-src/ Cannot open: File exists tar: blazingsql-files/nvstrings-src/LICENSE: Cannot open: File exists tar: blazingsql-files/nvstrings-src/conda/recipes/custrings/meta.yaml: Cannot open: File exists tar: blazingsql-files/nvstrings-src/conda/recipes/custrings/ Cannot open: File exists tar: blazingsql-files/nvstrings-src/conda/recipes/custrings: Cannot utime: Operation not permitted tar: blazingsql-files/nvstrings-src/conda/recipes/libcustrings/meta.yaml: Cannot open: File exists tar: blazingsql-files/nvstrings-src/conda/recipes/libcustrings/ Cannot open: File exists tar: blazingsql-files/nvstrings-src/conda/recipes/libcustrings: Cannot utime: Operation not permitted tar: blazingsql-files/nvstrings-src/conda/recipes: Cannot utime: Operation not permitted tar: blazingsql-files/nvstrings-src/conda/environments/builddocs_py36.yml: Cannot open: File exists

Posted by Corey about a month ago


CSV table create and SQL query error

Greetings to everyone I'm running tests on my server that supports Cuda 10.1. I'm using BlazingDB with docker container. But I get this error when I want to run sql using csv: "CUDA error encountered at: /home/builder/workspace/cudf_project/develop/cudf/cpp/src/io/utilities/ 8 cudaErrorInvalidDeviceFunction invalid device function" my nvidia-smi result is: +-----------------------------------------------------------------------------+ | NVIDIA-SMI 418.39 Driver Version: 418.39 CUDA Version: 10.1 | |-------------------------------+----------------------+----------------------+ | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC | | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. | |===============================+======================+======================| | 0 Quadro M4000 Off | 00000000:01:00.0 Off | N/A | | 46% 40C P8 11W / 120W | 99MiB / 8125MiB | 0% Default | +-------------------------------+----------------------+----------------------+ +-----------------------------------------------------------------------------+ | Processes: GPU Memory | | GPU PID Type Process name Usage | |=============================================================================| | 0 10067 C /home/jupyter/testing-libgdf 57MiB | | 0 27302 C /conda/envs/cudf/bin/python 56MiB | +-----------------------------------------------------------------------------+ and my test py is: from blazingsql import BlazingContext bc = BlazingContext() column_names = ['date','name'] column_types = ['str','str'] bc.create_table('gtd', '/blazingdb/data/csv/gtd2017.csv', delimiter=',', dtype=column_types, names=column_names) result2 = bc.sql('SELECT * FROM main.gtd', ['gtd']) result = result2.get() gdf = result2.columns print(gdf) Thanks.

Posted by Melih 2 months ago